USGlobalSat GPS Forums

Please login or register.

Login with username, password and session length
Advanced search  


Pages: 1 2 3 [4] 5 6 ... 10
 on: January 14, 2014, 01:16:57 am 
Started by Dmac - Last post by Dmac
About 3 weeks ago I did a run in the rain and later I noticed what looked like some moisture under the front plate. The functions were all working perfectly. Yesterday I also did a run in the rain and the watch also worked. I saved the run and switched it off. Today, I notice the "water" patch appears to be larger and the watch would not start the normal way. I tried pressing + and - and start buttons and it did start up and searched for satellites but as soon as I pressed any button, the data page switch from page to page very rapidly. Is there any solution to this?
3 days ago, I decided to apply some home remedies to revive the watch. A few hours in the tropical sun plus 5 minutes of hair dryer blast. The water patch appears to have shrunk a bit. Overnight, it shrank again. Tested the watch yesterday. It worked although the attitude reading is not correct. Distance appears to be OK but needs testing also. Taking it out for another go in the jungle today. Hope it does not rain.

 on: January 13, 2014, 08:42:42 am 
Started by sbouju - Last post by sbouju
Thank you GlobalSat, or thank you Garmin, or thank you both:

It is now possible to directly re-import in Garmin Connect the GPX export of a GH-625XT track collected in GSSTGP... :D

 on: January 12, 2014, 07:04:46 pm 
Started by DEPOM - Last post by gerhard
I assume that you have ST installed already.

Internet Explorer does not honor the extension for the downloaded file and handles it as a .zip file.
Save the file and rename it.

There were problems installing plugins in ST2 (or ST3.0 even?), but not in 3.1 that I am aware of.
If you still have a problem, the ST forum is a better start as this is not a Globalsat specific problem.

 on: January 11, 2014, 05:05:06 pm 
Started by jmanta - Last post by jmanta

Who can help with navigation and route functions...
I have a GB-590P and a GH-625XT. And for sure that the problem it’s on me ….
When I Upload a route via Gym Pro (.gpx file or KML file) appears a message saying that the data was send with success and in the device appears data loaded ok..but when I go to Navigation-routes-listall, I don’t see any date or any route…What I´m doing wrong?

Another question is when we record an activity, if we want this activity info later to follow the track, but record the date again, how can we do it? How can we use a record activity that we had done to navigate later and record at the same time?


 on: January 07, 2014, 04:36:19 pm 
Started by DEPOM - Last post by DEPOM

Who can tell me the way to put a Glosatplugin into sporttracks 3.1?

 on: January 07, 2014, 11:09:38 am 
Started by DEPOM - Last post by DEPOM
Now it works properly. ;)

 on: January 06, 2014, 05:03:34 pm 
Started by DEPOM - Last post by DEPOM
I have installed the drivers.
After that i've changed the com port

 on: January 06, 2014, 12:19:19 pm 
Started by DEPOM - Last post by USG_TECH9
Hello DEPOM,

Have you installed the USB driver? If so, does the GB-580 show up in your Device Manager under Ports as "STM Virtual COM Port(COMX)"? Drivers can be found here:

If so, you might need to manually set the COM port by going to Configuration > COM port settings and manually select the correct COM port number.

Please let me know if you're still having issues. Thanks


 on: January 04, 2014, 04:17:06 pm 
Started by DEPOM - Last post by DEPOM

I've got a problem with my GS 580P. As I installed the software on my computer and after i like to download the data from the device, gs sport trainer says.

Devive detection failed, please check for com port/baud rate settings

What have i done wrong?

regards from the Netherlands 

 on: January 03, 2014, 01:20:13 pm 
Started by Longjog @ GS-Sport-Servicecenter - Last post by Longjog @ GS-Sport-Servicecenter
... was it hacked? (2014-01-03)

Pages: 1 2 3 [4] 5 6 ... 10

Page created in 0.176 seconds with 15 queries.