USGlobalSat GPS Forums

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Need to switch back to NMEA Protocol  (Read 3509 times)

owindrich

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Need to switch back to NMEA Protocol
« on: March 30, 2011, 01:23:57 pm »

Hello Guys,
My MR-350 is switched to SiRF protocol while testing gps scripts on my Ubuntu notebook.
But I need to go back to NMEA protocol with "normal" NMEA TEXT output.

I tried to use SiRFDemo on windows to swith back, but that does't work.
I also used SirfTech.exe and that also did't help. Searching on Google did't helped me out on this.

My setup is the MR-350 with a USB cable on a Windows computer with the PL2303_Prolific_DriverInstaller_v130
driver on COM3 or on a Ubuntu Laptop running on /dev/ttyUSB0

On Ubuntu I can see the GPS in action with xgps, it still works only on the wrong protocol.

How can I get it done?
Help
Logged

GS_TECH01

  • Administrator
  • Hero Member
  • *****
  • Karma: 5
  • Offline Offline
  • Posts: 1755
Re: Need to switch back to NMEA Protocol
« Reply #1 on: March 30, 2011, 01:56:14 pm »

To revert back to NMEA mode, please follow the instructions below:

If you have an older version of the SiRFDemo, uninstall it and restart your computer.
(*Skip this step if you have the current one.)
Download and install this latest version (3.87): http://www.usglobalsat.com/store/downloads/SiRFDemo387.zip
Run the Sirf Demo software.
Connect your device, choose the correct COM port, and select the 4800 baud rate.
Go to Action > Open Data Source.
Next, go to Action > Switch to SiRF Protocol.
Then, go to Action > Switch to NMEA Protocol.
In the pop-up window, select the 4800 baud rate under the Baud Rate and click Send.
Close the Sirf Demo software.

Now, try testing your GPS Receiver with the GPSInfo program to see if the problem persists.
« Last Edit: February 29, 2012, 03:43:06 pm by USG_TECH10 »
Logged

owindrich

  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
Re: Need to switch back to NMEA Protocol
« Reply #2 on: March 30, 2011, 02:48:19 pm »


When I Connect my device, choose the correct COM port, and select the 4800 baud rate.
I get a POPUP message Select Target Software (I selected Auto detection)



then when I want to do the next step: Go to Action > Open Data Source.
I Can't go to: Next, go to Action > Switch to SiRF Protocol.



So, I do the next: Then, go to Action > Switch to NMEA Protocol.
Choose 4800 and Send



After that,I close the app and it's still the same.


Logged

GS_TECH01

  • Administrator
  • Hero Member
  • *****
  • Karma: 5
  • Offline Offline
  • Posts: 1755
Re: Need to switch back to NMEA Protocol
« Reply #3 on: March 30, 2011, 04:20:44 pm »

Please close any programs you have running. Also, make sure nothing is plugged into your computer.

Now, plugin the device to another USB Port. To check the com port, please look into your Device Manager. You can do this by pressing the Start (Windows) button. Right-click on Computer > Manage > Computer Management > System Tools > Device Manager > Ports (COM & LPT) > Prolific to USB Serial Comm Port (COMXX).

Open up SiRFDemo. The Data Source Setup window will show up. In the Serial Port, choose the com port and set the baud rate to 4800. Click OK. Go to Action > Initialize Data Source. In the Receiver Initialization window, select Factory Reset and click Send. That should be able to reset the unit to its default settings.

Let us know how it goes.
Logged
Pages: [1]   Go Up
 

Page created in 0.194 seconds with 20 queries.