USGlobalSat GPS Forums

Please login or register.

Login with username, password and session length
Advanced search  

News:

Pages: [1]   Go Down

Author Topic: Steady red light on - "No Position fix"  (Read 3394 times)

Frits

  • Regular Members
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Steady red light on - "No Position fix"
« on: July 31, 2012, 02:03:51 pm »

I have a new BU-353 and when it works it works fine. But most of the time it does not find the satellites. I have done all kind of things, trying on the roof of my house, outside in the garden and also inside under a skylight. In less then 10% of the attempts the red light starts blinking and when it starts it starts within a few minutes. It does not make a difference if I am inside or outside the house. I cannot find a reason why it does not work always. I have re-installed the prolific software, tried on other computers etc, etc.
If the red LED is blinking the reciever works perfect, I have had it on for several days without any problem, When the LED is blinking I can see it is ok in GPSInfo too.
Do you have any suggestions?
Logged

GS_TECH01

  • Administrator
  • Hero Member
  • *****
  • Karma: 5
  • Offline Offline
  • Posts: 1755
Re: Steady red light on - "No Position fix"
« Reply #1 on: July 31, 2012, 03:21:53 pm »

Just a couple of questions:

To confirm, is the model number of your device, the BU-353? Not the BR-355? Just asking because it's posted under the BR-355 forum section.
Can you please describe the testing environment? Are you surrounded by any tall trees or buildings around?
Or, do you have a clear access to an open sky? This environment would be the ideal one as explained further here: http://www.usglobalsat.com/forum/index.php?topic=3780.msg9921#msg9921
Have you tried performing Cold Start? If not, open up the GPSInfo and click on Start GPS. After a few seconds, press the Cold Start button to reset the device.
Logged

Frits

  • Regular Members
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Re: Steady red light on - "No Position fix"
« Reply #2 on: July 31, 2012, 03:43:02 pm »

It is a BU-353. I came on this forum section via the link "Forum Discussion" on the BU-353 support page: http://www.usglobalsat.com/s-122-bu-353-support.aspx . A wrong link?
I have clear access to open sky.
I have pressed the "Cold Start" button. GPSInfo replies with: $PSRF   ...OK. I do not see any changes off the LED light, it keeps  burning steady.
Logged

GS_TECH01

  • Administrator
  • Hero Member
  • *****
  • Karma: 5
  • Offline Offline
  • Posts: 1755
Re: Steady red light on - "No Position fix"
« Reply #3 on: July 31, 2012, 05:29:23 pm »

Thanks for confirming it's the BU-353.

Yes, it was not the proper link. Will go ahead and correct it. Thanks for pointing it out.

Thanks for providing info about the test environment. Just to confirm, you're not surrounded by any tall trees or buildings?

Regarding the Cold Start, did you see any scrolling data in the blank white window of the GPSInfo program after you pressed the Start GPS button?
If not, please make sure you have selected the proper com port and baud rate. Then, you can click on the Start GPS button, wait for a few seconds, and press the Cold Start button.
Logged

Frits

  • Regular Members
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Re: Steady red light on - "No Position fix"
« Reply #4 on: August 01, 2012, 05:23:42 am »

I am not surrounded by high trees or high buildings.
I have selected the right com port and baud rate. There is no scrolling data in GPSInfo. Only when the red LED is blinking and if I check with GPSInfo then I see scrolling data
Logged

Frits

  • Regular Members
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Re: Steady red light on - "No Position fix"
« Reply #5 on: August 01, 2012, 01:54:13 pm »

If I look in SiRFDemo and press "Action" and than "Open Data Source" the error view gives the next messages:
Warning: PurgeComm[] failed
Warning: SetCommState[] failed in CSerialComm: Open
Warning: SetupComm[0x1000] failed
Warning SetupComm[] failed
Comm: CE_FRAME

Repeating the last message endless
Gives this usefull information to you?
Logged

GS_TECH01

  • Administrator
  • Hero Member
  • *****
  • Karma: 5
  • Offline Offline
  • Posts: 1755
Re: Steady red light on - "No Position fix"
« Reply #6 on: August 01, 2012, 03:37:55 pm »

That's strange. Whether the LED is blinking or just steady on, you should be able to see scrolling data in the GPSInfo no matter what. Have you tried plugging the device to another USB port? If not, please do so and confirm that it's installed properly in the Device Manager.

Open up the SiRFDemo program, select the com port, and choose the correct baud rate. Go to Action > Open Data Source.
If you see scrolling data in the Error View window, go to Action > Synchronize Protocol & Baud Rate.
Keep doing this until you se scrolling data in the Debug View window.

If you see scrolling data in the Response View window, you can try the following steps to switch it back to NMEA:
1. Connect your device, choose the correct COM port, and select the 4800 baud rate.
2. Go to Action > Open Data Source.
3. Next, go to Action > Synchronize Protocol & baud rate.
4. Then, go to Action > Switch to NMEA Protocol.
5. In the pop-up window, select the 4800 baud rate under the Baud Rate and click Send.
6. Close the Sirf Demo software.
Now, try the BU-353 with the GPSInfo Utility and see if you're able to see the scrolling data.

Note: Be sure and not to click on anything else in this software, as you can render your device unusable.
Logged

Frits

  • Regular Members
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Re: Steady red light on - "No Position fix"
« Reply #7 on: August 02, 2012, 02:34:10 pm »

I have tried an other USB port, but this gave the same result (checked in device manager for other COM port)
I have done the action in the SIRFDemo program. I have done the action "Synchronize Protocol & Baud Rate" a lot, but never got scrolling data in the Debug View window. At the top of the screen, in the blue line I can see it always stops at COM8/57600 (COM 8 is the correct com port)

Logged

GS_TECH01

  • Administrator
  • Hero Member
  • *****
  • Karma: 5
  • Offline Offline
  • Posts: 1755
Re: Steady red light on - "No Position fix"
« Reply #8 on: August 02, 2012, 04:21:31 pm »

After you selected the 'Synchronize Protocol & Baud Rate' and let it run for awhile, do you still see scrolling messages in the Error View window? If so, just keep selecting Synchronize Protocol & Baud Rate until you see some messages in the Response View or Debug View window.

If you saw some scrolling message in the Response view window, please follow the instructions above on how to switch it back to NMEA.
Logged

Frits

  • Regular Members
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Re: Steady red light on - "No Position fix"
« Reply #9 on: August 03, 2012, 12:43:47 pm »

I have selected Synchronize Protocol & Baud Rate for more than 70 times now, but no differences  ::). Is there hope ;D
There are still scrolling messages in the error view window(Comm: CE_FRAME)
Logged

GS_TECH01

  • Administrator
  • Hero Member
  • *****
  • Karma: 5
  • Offline Offline
  • Posts: 1755
Re: Steady red light on - "No Position fix"
« Reply #10 on: August 03, 2012, 05:02:53 pm »

Just wondering, before you use the SiRFDemo, was the device outputting data with the GPSInfo?
If so, did you make any changes/updates with the computer before using the SiRFDemo?
Also, how were you able to setup the BU-353 with the SiRFDemo? Can you please provide a step by step procedures?
Did you click on any selections/options in the program?

By the way, what is the operating system and version of your computer?
Perhaps, you can reset the unit back to its default settings by unplugging this device/leaving it alone for about 72 hours.

Also, in order to provide further support, can you please register the product and generate a support ticket? We recommend that you visit our website: (http://www.usglobalsat.com/store/signin.aspx?ReturnURL=/store/support/). Register your product and generate a "Support Ticket" from within our system.

If you had purchased the item from the USGlobalSat website, you should already have a customer account and password. You can immediately log-in using that info. If you purchased it from one of our authorized resellers, you will need to establish a NEW account at: http://www.usglobalsat.com/store/createaccount.aspx

By working within our support structure, we do not only address your specifc issue in a timely manner, but also maintain a history of your incident to ensure that it is handled with appropriate actions. It's not only now, but for all potential future communications as well.

We again thank you for your patience and cooperation.

WARRANTY POLICY

Please read our posted warranty policy, especially on how it pertains to sellers of USGlobalSat product on e-Bay & other unauthorized resellers: http://www.usglobalsat.com/s-131-terms-conditions.aspx#12
Logged

Frits

  • Regular Members
  • *
  • Karma: 0
  • Offline Offline
  • Posts: 7
Re: Steady red light on - "No Position fix"
« Reply #11 on: August 06, 2012, 12:48:20 pm »

I want to use the device on a Medion netbook with Windows XP, SP3. But I also tried on HP laptops with Vista and Windows 7, all with the same result.
What have I done this weekend, I kept the GPS device alone for about 72 hours. When I plugged it in again it did not work.
Then I removed the Prolific software from the computer, put the computer off for a few minutes and reinstalled the Profilic software. When I connected the GPS device again it worked!! Now I have scrolling data in GPSInfo too. Also SIRF Demo gives scrolling data after Open Data Source (with correct settings off course). Also my navigation programm is working well.
Ok, I am glad now, because it is working again, but I am afraid when disconnecting the GPS reciever it all starts over again.
I have fixed this in the same way before, as well with the XP machine as with the Windows 7 machine, but last week it did not work that way.
Do you have suggestions how to proceed now, I think I am close to a solution. If not I will make a "Support Ticket"
Logged

GS_TECH01

  • Administrator
  • Hero Member
  • *****
  • Karma: 5
  • Offline Offline
  • Posts: 1755
Re: Steady red light on - "No Position fix"
« Reply #12 on: August 06, 2012, 01:40:52 pm »

Thanks for the update. And, good to hear that it's working fine now.

Perhaps, the issue lies with the driver. If you installed the driver from the CD, it's possibly a previous version. However, if you installed the driver directly from our website (http://www.usglobalsat.com/s-24-support-drivers.aspx), you would have the current version. We usually recommend to get the drivers from our website because we regularly update the drivers.

Since uninstalling and reinstalling the driver fixed the problem, then, there should be no need to this again. You just to have make sure that the driver is properly removed and it's successfully installed. If you experience this problem again, please register the product and generate a support ticket.

If you have any questions, just let me know. Thanks.
Logged
Pages: [1]   Go Up
 

Page created in 0.437 seconds with 26 queries.